viernes, 23 de enero de 2009

Activar Aceleracion 3D GeForce 6150SE nForce 430


nvidia_geforce_300

Bueno ahora con placa nueva paso a explicar como le hice para poder activar la aceleración 3D de mi tarjeta gráfica.... GeForce 6150SE nForce 430......

Utilicé los Drivers de nVidia para darle de alta a la aceleración, bueno este es el driver que usé yo:

$wget http://us.download.nvidia.com/XFree86/Linux-x86/177.82/NVIDIA-Linux-x86-177.82-pkg1.run

Una ves que termine la descarga pasamos a instalar los siguientes paquetes:

#apt-get install binutils build-essential

#apt-get install pkg-config xserver-xorg-dev xorg-dev

#apt-get install linux-source-2.6.26 linux-headers-2.6.26-1-686 (bueno ese es mi kernel actual ahi ponen el suyo

ahora necesitamos terminar el servidor gráfico... tecleamos Ctrl+Alt+F1... y luego los siguientes comandos como ROOT:

#init 3

#/etc/init.d/gdm stop (yo uso Gnome si usas KDE o XFCE seria kdm o xdm según en ves de gdm)

ahora nos vamos al directorio donde descargamos el driver de nVidia, una ves ahi el siguiente comando:

#sh NVIDIA-Linux-x86-1.0-9746-pkg1.run

si les arroja que no tiene permisos de ejecución pues hacen:

#chmod +x NVIDIA-Linux-x86-1.0-9746-pkg1.run

Aceptamos la licencia, en Configurar Kernel decimos Yes, si pregunta algo de libgcc le decimos que NO e imediatamente veras una barra de progreso, quiere decir que se encuentra instalando, va a preguntar si deseamos que configure el Xorg de manera automatica le decimos YES y debe terminar la instalación... pasemos a comprobar el driver con el comando:

#modprobe nvidia (si está instalado correctamente no arroja nada, pero si no marca algún tipo de error)

ahora iniciamos el GDM en mi caso:

#/etc/init.d/gdm start

ahora hasta aquí un detalle... la distribución de mi teclado me la dejó en Inglés.. bueno eso lo cambié en Sistema>Preferencia>Teclado luego en la pestaña de distribución añado latinoamericano en mi caso y quito el inglés.... ahora a modificar el xorg... como root:

#nano /etc/X11/xorg.conf

en la sección “Devices” agregamos los siguiente... ojo con las comillas:

Option "RenderAccel" "true"
Option "AllowGLXWithComposite" "true"

ahora comprobamos si tenemos aceleracion 3D de la siguiente forma:

$glxinfo | grep direct

les debe arrojar lo siguiente:

direct rendering: Yes

o también con la aplicacion:

$glxgears

si los engranes giran a la misma velocidad cuando maximizas la ventana entonces tienes aceleración 3D.... bueno ahora si no reconoce los comandos glxinfo y glxgears instalate el paquete siguiente para que los reconozca:

#apt-get install mesa-utils

hasta este punto ya debemos tener la aceleración activada...

19 comentarios:

Anónimo dijo...

hey amigo, ahi estoi bajando esos paquetes, espero que me funcionen xq nose como activarlo, muchas gracias (:

╬vιсмεтαʟ╬ on 30 de junio de 2009, 3:04 dijo...

oye we la mera neta no te entiendo... si podes explicarme mejor te lo agradeceria..... saludos!!!

Pyr0S-9889 on 30 de junio de 2009, 14:52 dijo...

Que tal ╬vιсмεтαʟ╬:

Qué parte exactamente no entiendes?.. ¿En qué distro quieres instalar el Driver?

ahora... Ya descargaste el Driver de nVidia que pongo aquí?.. si no es así, descargalo con el comando:

$wget http://us.download.nvidia.com/XFree86/Linux-x86/177.82/NVIDIA-Linux-x86-177.82-pkg1.run

si me das más datos, con gusto te ayudo.. Saludos!!

Pyr0S-9889 on 20 de diciembre de 2009, 13:05 dijo...

Ahora tengo el kernel 2.6.30 y no funciona el driver que pongo en la entrada, porque hay nuevo jejeje:

http://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/XFree86/Linux-x86/190.53/NVIDIA-Linux-x86-190.53-pkg1.run&lang=us&type=GeForce

Saludos!

Jose Vicmas on 6 de enero de 2010, 17:56 dijo...

primero que nada feliz año y gracias por estos aportes.
tengo un problema cuando termino el servidor me pasa ala pantalla negra y ahi pues me pide usuario y clave y no me lo acepta por lo tanto tengo que reiniciar y volver a entrar aqui y la unica opcion es hacerlo todo por terminal y pues no tengo resultados del controlador por que no puedo activar nada.

Pyr0S-9889 on 6 de enero de 2010, 18:43 dijo...

Saludos @Jose, feliz año...

unas preguntas, que distro usas?, que kernel tienes instalado?.. sé un poco más detallado...

espero tus respuestas para poder ayudarte

Jose Vicmas on 19 de abril de 2010, 14:59 dijo...

Disculpe que tarde respondi pero es que tuve problemas de trabajo y no pude continuar ahora ya instale 10.04 beta 2 y si tengo aceleracion grafica gracias aun y cuadno quise instalar este driver que me dices no me deja me da un error en la instalacion ( ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.)

Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find
suggestions on fixing installation problems in the README available
on the Linux driver download page at www.nvidia.com.

Esto me pone y de ahi no paso.
no se que problema tenga aun que le digo que si pongo.

root@jose-BETA2:~# glxinfo | grep direct
direct rendering: Yes

y si veo los engranes que corren a la misma velocidad.
aun que no tengo este controlador activado me instalo uno de los 3 ue vienen ya por defaul y no me instalo el recomendado sino el primero , cuando instalo el recomendado no puedo iniciar de nuevo.
saludos
JOSE VICMAS

Pyr0S-9889 on 19 de abril de 2010, 22:16 dijo...

@Jose Vimas

Que tal man.. tarde pero seguro! xD eso me gusta jejeje....

Por lo que leo, usas Ubuntu 10.04, y te instala automáticamente el modulo y activa la aceleración.

Ahora, el error que te marca, se debe a que no terminas el servidor gráfico, el hecho de que cambies con CTRL+ALT+F1 a modo texto, no quiere decir que hayas terminado el servidor gráfico, los pasos que te comes son estos:

#init 3

#/etc/init.d/gdm stop (yo uso Gnome si usas KDE o XFCE seria kdm o xdm según en ves de gdm)

mira, en ubuntu creo que no te deja loggear como root directamente en modo texto, primero una ves estando en modo texto, loggeate como tu user normal, luego con sudo su pasas a root

espero haberme dado a entender, si no, por favor házmelo saber.

Que estés bien man, y siguele dando!

Jose Vicmas on 19 de abril de 2010, 22:45 dijo...

Eso es todo mi amigo tu si que estas al pie del cañon y respondes de volada, pro eso estamos aqui siempre fieles.
puse como me dices init 3 y si me pasa luego me logeo como root y si hago todo eso despues de poner
#/etc/init.d/gdm stop, lo hago todo esto pasa perfectamente y despues de ahi me da el error aun asi.
no se que tenga de problema pero no me pasa de ahi ahora como te digo, si tengo aceleracion y los engranes dan vuelta perfectamente. pero, pero , pero no tengo instalado el controlador que es para esta tarjeta. Eso es lo unico que me tiene pensando, ahora cuando ya liberen en su totalidad 10.04 instalaremos todo de nuevo y ahi estaremos viendo que pasa.
muchas gracias por su apoyo y si algo hay que hacer en este caso pues lo hacemos total no pasa que no se inicie y si es asi pues volvemos a instalar, lo bueno de ubuntu es que solo instalas raiz el home me lo guardo asi que no me preocupo tanto por que todo se me respalda.

saludos
JOSE

Pyr0S-9889 on 20 de abril de 2010, 0:05 dijo...

@Jose

mmmmm... yo a veces para matar bien bien el server hago un (todo como root en modo texto):

killall gdm

o con un:

ps -A|grep gdm
kill pid

donde pid es el numero del proceso que arroja tras el comando ps -A|grep gdm, y creo recordar, que también me costó un poco parar bien el servidor la última ves que instalé el modulo.

bueno es sólo cuestión de matar el proceso gdm o kdm, no estoy seguro de éste último si así se llame en entorno KDE...

pero bueno, como dices, ya veremos en la versión 10.04 final, del ubuntu si no ha salido, que la neta no sé :S jejejeje, ando bien pero bien ido estos últimos meses.

y creo que insisto mucho en darle vueltas al asunto, pero así soy, no me quedo conforme hasta solucionar las cosas jejejeje.

Saludos bro!

PD: ya me voy a jetear, mañana tengo exámen a las 7 de la madrugada... haa joder, que ya no es mañana es hoy jejeje.. en fin....

Pyr0S-9889 on 20 de abril de 2010, 0:07 dijo...

haaaa una última cosa, checa que en un comentario puse un link del nuevo modulo que me funcionó en el kernel 2.6.30, el que pongo en el post no me funcionó.

Jose Vicmas on 21 de abril de 2010, 10:38 dijo...

Que tal amigo, ya quedo con esas ultimas opciones que me diste de matar bien el server quedo perfecto.
ahora si ya revisando tengo el ultimo driver instalado y perfecto.
Todo funciona bien compiz y todo.
lo que si como referencia es que ahora batalla un poco para ingresar como que hace todo el proceso al inicio y luego entra, no es problema para mi pues no necesito que sea rapidisima para encender. Solo es comentario.
saludos y aqui seguiremos para las preguntas que vayan saliendo.
claro si me lo permites.

saludos
JOSE

Jose Vicmas on 1 de mayo de 2010, 12:10 dijo...

Amigo aqui estamos de nuevo.
Ahora tengo otro problema, ya instale la version final de 10.04 lts y obvio instale el ultimo driver de mi nvidia, la instalo y hago todo le procedimiento que la anterior ves e ingresa perfectamente, y funcional y todo, pero, pero, al apagar la compu y volver a encenderla se queda en pantalla negra sin servidor grafico y ahi entro a terminal y hago todo , y no ingresa, vuelvo a instalar el driver y en ese momento ingresa de nuevo, pero obvio no puedo estar haciendo esto siempre.
TEndra algun comentario?
gracias
JOSE

Pyr0S-9889 on 1 de mayo de 2010, 12:50 dijo...

@Jose

Que tal bro, no he probado personalmente la nueva versión de Ubuntu, pero busqué un poquito por google y encontré esto:

http://www.ubuntugeek.com/howto-install-nvidia-drivers-manually-on-ubuntu-10-04-lucid-lynx.html

no estoy muy seguro si por ahí está el error que te ocurre a tí, pero espero que te sirva, de todos modos, si logras solucionarlo de alguna otra forma o si tienes más dudas me las comentes por aquí, para estar enterados...

Saludos Jose y siguele dando!

Jose Vicmas on 1 de mayo de 2010, 16:26 dijo...

amigo buenas tardes como siempre me sacas del apuro, pues al parecer esto es, lo que me pasaste en este ultimo link, pero sabes que principalmente fue el eliminar todo lo relacionado con nvidia el purgar es lo que me sirvio por que al fin use el mismo driver.
ya funciona bueno por el momento tengo todo lo que necesito.
probaremos durante el dia o veremos en algunos dias haber como acontence, si te puedo decir que este ultimo 10.04 lts final cuando menos en mi maquina vuela, es muy rapido.
veremos como se comporta cuando lo estemos cargando de programas y ya en manejo diario.
saludos
seguimos en contacto
JOSE

Pyr0S-9889 on 1 de mayo de 2010, 19:13 dijo...

@Jose

Que bien que te haya funcionado bro, espero y me comentes tus impresiones sobre el Ubuntu 10.04, yo a lo mejor más tarde me descargo el iso...

por ahora me sigo peleando con un AP en modo repetidor.... que me está costando ò_ó pero ya lo heché a andar XD... sólo faltan más pruebas...

bueno bro, que estés bien. Saludos.

Jose Vicmas on 6 de mayo de 2010, 13:01 dijo...

Mis comentarios al dia de hoy, es perfecto, es rapido, fuciona de maravilla, os programas voy probandolos poco a poco, no tengo problemas, lo unico fue lo que detallo aqui respecto al driver de tarjeta grafica.
seguire comentando, mi trabajo poco me deja ver completamente solo en las noches logro entrar.
estoy bajando la version de lubuntu que es nueva e igual la instalaremos veremos como se comporta.

Anónimo dijo...

2.6.28-19-generic


ii linux-image-2.6.28-11-generic 2.6.28-11.42 Linux kernel image for version 2.6.28 on x86

ii linux-image-2.6.28-19-generic 2.6.28-19.61 Linux kernel image for version 2.6.28 on x86

ii linux-image-generic 2.6.28.19.24 Generic Linux kernel image



Ese es mi kernel y por ende no puedo instalar el driver, que puedo hacer? gracias de antemano

Pyr0S-9889 on 13 de septiembre de 2010, 23:00 dijo...

busca entre los comments puse una nueva version del driver, prueba con ese. Saludos

Publicar un comentario

 

Pyr0S-9889 © 2008 Business Ads Ready is Designed by Ipiet Supported by Tadpole's Notez